add debian packaging
[roojspacker] / roojspacker / CMakeLists.txt
index 753677a..682c126 100644 (file)
@@ -127,10 +127,11 @@ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${ROOJSPACKER_PKG_NAME}.vapi
     DESTINATION ${CMAKE_INSTALL_DATADIR}/vala/vapi)
 
 # Install the library
-install (TARGETS ${ROOJSPACKER_LIBRARY_NAME}
-    RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}  # On Windows, the DLL goes in the same place as the executables
-    LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}  # This is where shared libraries (*.so on Linux, *.dynlib on OS X)
-    ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}) # Finally, this is where static libraries (*.a) go
+install (
+    TARGETS ${ROOJSPACKER_LIBRARY_NAME}
+    RUNTIME DESTINATION bin  # On Windows, the DLL goes in the same place as the executables
+    LIBRARY DESTINATION lib  # This is where shared libraries (*.so on Linux, *.dynlib on OS X)
+    ARCHIVE DESTINATION lib) # Finally, this is where static libraries (*.a) go
 
 # Install the C header
 install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${ROOJSPACKER_PKG_NAME}.h
@@ -167,4 +168,4 @@ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${ROOJSPACKER_PKG_NAME}.pc
 #        DESTINATION "${CMAKE_INSTALL_DATADIR}/devhelp/books")
 #    add_custom_target(doc ALL
 #        DEPENDS html devhelp)
-#endif()
\ No newline at end of file
+#endif()