trying to get deb-build working
[roojspacker] / debian / rules
index 3d14df5..2d8809e 100755 (executable)
@@ -1,7 +1,7 @@
 #!/usr/bin/make -f
 # See debhelper(7) (uncomment to enable)
 # output every command that modifies files on the build system.
-#export DH_VERBOSE = 1
+export DH_VERBOSE = 1
 
 
 # see FEATURE AREAS in dpkg-buildflags(1)
@@ -13,6 +13,9 @@
 # package maintainers to append LDFLAGS
 #export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
 
+override_dh_auto_test:
+override_dh_usrlocal:
+
 
 %:
        dh $@ --buildsystem=cmake 
@@ -20,6 +23,6 @@
 
 # dh_make generated override targets
 # This is example for Cmake (See https://bugs.debian.org/641051 )
-#override_dh_auto_configure:
-#      dh_auto_configure -- #  -DCMAKE_LIBRARY_PATH=$(DEB_HOST_MULTIARCH)
+override_dh_auto_configure:
+       dh_auto_configure -- -DCMAKE_LIBRARY_PATH=$(DEB_HOST_MULTIARCH) -DCMAKE_INSTALL_BINDIR=$(DEB_HOST_MULTIARCH)/bin -DCMAKE_INSTALL_LIBDIR=$(DEB_HOST_MULTIARCH)/lib