Merge branch 'master' of http://git.roojs.com/roobuilder
[roobuilder] / debian / changelog
index 2d2bb10..e874f6b 100644 (file)
@@ -1,4 +1,53 @@
-roobuilder (5.0.1) UNRELEASED; urgency=medium
+roobuilder (5.0.4) UNRELEASED; urgency=medium
+
+  * error popups with tree of errors, now default to expanding current file
+  * row detection for drag/drop + contect menu replaced with pick/ bounds and row counting (far more reliable)
+  * css moved to resource
+  * editor resize font now centralized and synced on all windows
+  * added back roopacker dependancy (uses threaded compile)
+  * reference to wishlist on readme
+  * support for structs when adding objects (eg. CClosureExpression)
+  * editor font size uses ctrl-scroll to enlarges / shrink
+  * fixed issue with missing references on node creation
+  * completion now uses editor context to decide if to try and complete
+  * target names in gtk settings only support a-z
+  * file dialogs can be closed with esc key
+  * added library support for meson creation, including version and licence in settings
+  
+
+ -- Alan <alan@roojs.com>  Wed, 07 Feb 2024 09:51:44 +0800
+
+roobuilder (5.0.2) unstable; urgency=medium
+
+  * support for extended writing of vala applications
+    Note that sealed classes causes issues, so generally it's not usable yet
+  * Move Node (drag with shift pressed)
+  * Changing property key now triggers save/language server
+  * Fixed sending wrong 'save' to language-server (caused LS to crash)
+  * Fixed Gtkview - uses toSource(), rather than file.get_contents()
+  * Fixed updating of errors (should only update changed error mark or tree item))
+  * Errors now shown on widget tree / node properties / and node edit as selected
+  * Error highlighting now on character location of errors, along with marks
+  * roojspacker dependancy removed for now (too slow to work currently)
+  * add other property - use menubutton and tidy up pulldown so it looks like a menu.
+  * switch window now uses libadwadi panel
+  * switch window search shows full file list in panel - so you can jump to file
+  * control-o tiggers file open, after file serach up/down arrows select file, and enter / shift enter will open.
+  * undo and redo buttons - now work
+  * improved performance on node generation, and language server call performance (less uneccessary calls)
+  * use find path for searching for vala-language-server (and add it as a dependancy!)
+  * support for Adw in rendering of previews (limited though)
+  * remove readonly properties from palete 
+  * added icons from glade (and made the resources)
+  * added resource support to meson creation
+  * added gdb / gnome-terminal / meson / ninja to control file
+  * removed gda dependancy ( not used at present)
+  * flatpack might work...
+  
+  
+ -- Alan Knowles <alan@roojs.com>  Sun, 28 Jan 2024 06:54:56 +0800
+
+roobuilder (5.0.1) unstable; urgency=medium
 
   * switch to meson build
   * remove internal compiler - switch to call meson/ninja